Ich habe einen variablen Wert in eine Alarmbenachrichtigung eingefügt (z.B. {{close}}), aber diese funktionier nicht.

Die Wertersetzung in Bezug auf alertcondition() funktioniert nur für Skripte, die in Pine v4 oder höher geschrieben wurden. Wenn beim Auslösen des Alarms die Variablen in der Beschreibung nicht durch Werte ersetzt werden (z.B. wird Close = {{close}} statt Close = 45.1 angezeigt), ist der Indikator mit der alertcondition() wahrscheinlich auf einer früheren Version von Pine geschrieben und die Variablenbeschreibungen funktionieren nicht.

Folgendermaßen funktioniert es in Pine v4 oder höher:

Und so sieht es mit früheren Pine Versionen aus:


Dies geschieht auch dann, wenn Sie die Variable im Feld "Nachricht" im Dialogfeld "Alarm" hinzufügen (ohne den Code selbst zu bearbeiten). Wenn Sie die Variable dort hinzufügen und sie nicht ersetzt wird, wenn der Alarm ausgelöst wird, wird der Indikator höchstwahrscheinlich in Pine v3 oder älter geschrieben.

Wenn es sich um Ihr Skript handelt, können Sie unseren Konverter verwenden, um ein v3-Skript in v4 zu konvertieren. Mehr über das Feature können Sie hier lesen. Wenn das Skript von der öffentlichen Bibliothek ist, können Sie den Autor kontaktieren und ihn bitten, den Indikator auf v4 zu aktualisieren.

Startseite Aktien-Screener Forex-Screener Krypto-Screener Wirtschaftskalender So funktioniert es! Chartmerkmale Preise Einen Freund empfehlen Hausregeln Hilfe Center Webseite & Brokerlösungen Widgets Charting Lösungen Lightweight Charting Library Blog & News Twitter
Profil Profileinstellungen Konto und Abrechnung Einen Freund empfehlen Meine Support Tickets Hilfe Center Veröffentlichte Ideen Followers Ich folge Private Nachrichten Chat Abmelden